跳转至

POJ-2063 Investment(动态规划 完全背包)

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. Assume the following bonds are available:

Value Annual interest
4000 400
3000 250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). The following line contains a single number: the number d (1 <= d <= 10) of available bonds. The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main()
{
    int caseNum;
    cin >> caseNum;

    while (caseNum--){
        int capital, year, typeNum;
        cin >> capital >> year;
        cin >> typeNum;

        vector<int> weight(typeNum), value(typeNum);
        for (int i = 0; i < typeNum; ++i){
            cin >> weight[i];
            weight[i] /= 1000;
            cin >> value[i];
        }

        vector<int> d(50000, 0);
        for (int i = 1; i <= year; ++i){
            int sum = capital / 1000;
            for (int k = 0; k < typeNum; ++k){
                for (int j = weight[k]; j <= sum; ++j){
                    d[j] = max(d[j], d[j - weight[k]] + value[k]);
                }
            }
            capital += d[sum];
            if (i != year) fill(d.begin(), d.begin() + sum + 1, 0);
        }

        cout << capital << endl;
    }

    return 0;
}

此题相当于转化成背包容量可变化的完全背包问题,对于每一年需要重新计算背包容量。另外考虑的一点就是内存限制,最大数值1000000,并且债券价值始终是1000的倍数,利率不超过10%,那么把债券价值都除以1000可以减小数组的容量,计算最大开销:1000\times (1+10\%)^{40}\approx 45259, 那么数组开到50000即可。我们用d[j]表示背包容量为j时所能获得的最大利润。另外一个细节就是,每一年结束后都需要对数组d[]进行清空,但是最后一年就不需要了。